Shared Files "Browse Button" Not Displaying

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
10/17/2012 11:33:29 AM
Gravatar
Total Posts 199

Shared Files "Browse Button" Not Displaying

using version: 2.3.8.5

I added a Shared Files feature to the page and the when logged in the browse button does not display.  I do see the Create new folder button and also the upload button. If I click the area where it is supposed to be the browse functionality does fire

Do I need to enable a setting or is this a CSS change I need to make?

thank you in advance

10/17/2012 11:37:14 AM
Gravatar
Total Posts 2169

Re: Shared Files "Browse Button" Not Displaying

We've noticed this recently but only in Firefox. Are you using Firefox or another browser?

Regarding Firefox, we've not found a way to fix it.

Thanks,
Joe D.

10/17/2012 12:02:59 PM
Gravatar
Total Posts 199

Re: Shared Files "Browse Button" Not Displaying

thanks for the reply - Is this fixed in the latest release?

I am using FireFox - But I want to avoid telling everyone if they want to use Shared files to use IE.

when I look at the code from a rendered page it looks like the display is set to none

            <div id='NeatUploadDiv_ctl00_mainContent_ctl01_multiFile' style='position: relative; display: none;'>
<input type="submit" name="ctl00$mainContent$ctl01$btnAddFile" value="Add File..." id="ctl00_mainContent_ctl01_btnAddFile" class=" jqbutton ui-button ui-widget ui-state-default ui-corner-all" />
</div>

 

10/17/2012 12:29:45 PM
Gravatar
Total Posts 2169

Re: Shared Files "Browse Button" Not Displaying

As I said in my previous post. We've not found a way to fix it. It's a problem with NeatUpload, not mojoPortal.

Thanks,
Joe D.

10/17/2012 1:49:33 PM
Gravatar
Total Posts 18439

Re: Shared Files "Browse Button" Not Displaying

I think Firefox is putting out automatic updates too fast and releasing buggy versions myself.

This is an odd one that I have not been able to figure out a "good" solution for, but with some experimenting I found that by adding this in the css:

.fileupload embed { background-color:inherit !important; padding:9px 9px 9px 9px; }

the button is partially visible but still has a white line through it and for it to work you have to click right on the white line part of the button because that is the actual flash object. It just seems the flash object itself is white in Firefox obscuring the button which should show through it like in other browsers.

Wish I had a better solution but at the moment I don't and the above fix doesn't seem to have any negative side effects in other browsers.

Best,

Joe

10/18/2012 7:48:30 AM
Gravatar
Total Posts 199

Re: Shared Files "Browse Button" Not Displaying

Thanks Joe, that css add helped.  I agree regarding the FF updates, seems like  FF releases an update once every two weeks or so.  I am currently running 16.0.1.

thanks again

 

You must sign in to post in the forums. This thread is closed to new posts.