timeout on neat uploads

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
8/27/2012 11:08:53 AM
Gravatar
Total Posts 199

timeout on neat uploads

I upload large files around 35MB and get a timeout error in the system log.

if I un-comment this line the site goes down:

<httpRuntime maxRequestLength="97151" executionTimeout="1000" useFullyQualifiedRedirectUrl="true"/>

I followed the article here and still having trouble : http://www.mojoportal.com/supporting-large-file-uploads.aspx

I am running in full trust.

my applicationHost.config override is set to allow

<neatUpload useHttpModule="true"
maxNormalRequestLength="97151"
maxRequestLength="97151"
multiRequestUploadHandlerUrl="~/NeatUpload/MultiRequestUploadHandler.ashx"
maxUploadRate="300" xmlns="http://www.brettle.com/neatupload/config/2008">
</neatUpload>

<security>
<requestFiltering>
<requestLimits maxAllowedContentLength="50000000"/>
</requestFiltering>
</security>

8/27/2012 11:24:06 AM
Gravatar
Total Posts 18444

Re: timeout on neat uploads

There already exists an httpRuntime element in Web.config so uncommenting would create 2 and cause an error. You should just add a longer executionTimeout attribute on the one that is already there.

I would not put NeatUpload settings in applicationHost.config, I would just keep that in web.config. The maxRequestLength on the NeatUpload is for uploads so be careful what you limit that to, maxNormalRequestLength is for limiting non upload requests. You could also remove the maxUploadRate attribute so that upload speed is not throttled.

 

8/27/2012 12:07:49 PM
Gravatar
Total Posts 199

Re: timeout on neat uploads

thanks Joe, timeout increase worked great.

the app host file config I made sure not to change anything there.

I also needed to keep the "neat upload section" - maxNormalRequestLength the same as maxRequestLength or I was getting a strange "non file portion max exceeded error "

all is well now - thanks.

You must sign in to post in the forums. This thread is closed to new posts.