Background Color Will Not Change

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
10/20/2011 2:37:05 PM
Gravatar
Total Posts 148

Background Color Will Not Change

I changed the definition for pagebody in the style.css file that is located in my Sites\1\skins\(skin name) folder and nothing happens.

body { color:#666; background-color:#fff; font:70%/1.5em Verdana, Tahoma, Arial,sans-serif; margin:0; padding:0; } .pagebody { color:#000; background-color:#000; background:#fff url('bg.gif') repeat-x; text-align:center; }

 

I even changed the file bg.gif to be one large black image...nothing happens.

Why isn't the background black?

10/20/2011 3:15:08 PM
Gravatar
Total Posts 1196
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Background Color Will Not Change

You need to turn off caching. To do it for your session only, go to Administration, Advanced Tools, Design Tools, Cache Tool, and click the Disable CSS Caching button.

You can also turn off caching for everyone. See the skinning overview document for more information.

When you're done working, you can copy your skin directory to a new name, then choose that new skin as the site skin. This will force a cache refresh for all visitors.

Jamie

10/20/2011 4:26:03 PM
Gravatar
Total Posts 148

Re: Background Color Will Not Change

I have caching turned off, however I found out what the problem was...after you clear the cache you need to refresh or the browser (IE9) will still show what's in memory.  This is the case even if you close the browser.

You must sign in to post in the forums. This thread is closed to new posts.