Upgrade with multi-site problem

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
5/7/2011 2:30:07 PM
Total Posts 31

Upgrade with multi-site problem


I had an installation of mojo version which had multiple sites, via hostname mapping (same ip).  

I tried to upgrade to but I ran into a few problem (host problems with .net version, permissions, etc). Finally, I created a new folder on my server, uploaded the full distro of to it's own folder.  I then repointed my webserver to the new directory.  Once I set a new skin,  the primary site worked without any problems.  

Because I uploaded to a new folder, the new install only had a Site 1 folder.  I first tried to copy the old site 2,3,4 folders into the new install, but then ran into the problem that the templates/skins are different then they were in so I removed them.  I then copied the Site 1 folder to 2, 3, 4 folders hoping that mojo would just work.

One of the sub-sites works which happens to be Site 4.  I can access that site without any problems.

When I try to access Sites 2 & 3, my browser prompts for a login.

"The server blah.domain.com requires a username / password"

I thought it was a permissions issue, so I double checked that permissions for all site folders were the same.  I even removed permissions from 2 & 3 and then reapplied them.

I'm still getting the problem.  There is nothing in the mojo current.config.

Do you have any ideas on where I should look?  Is this as website/permission issue?


Thanks in advance for your help with this.


5/8/2011 8:23:45 AM
Total Posts 18439

Re: Upgrade with multi-site problem

Hi Chris,

It sounds like file system permission problems where the thread that is executing does not have permission on some files so it prompts for a different user (maybe you have basic or digest authentication enabled, I think otherwise those requests would just fail with access denied).

The user that needs permissions is the user that is the identity on the app pool.

You upgraded from a very old version that ran under .NET 2, hopefully you went all the way to .NET 4. Possibly your host had to physically move your site to a different machine to give you a newer version of .NET or by changing to a .NET 4 app pool it may have a different identity. Moving a site can result in some funky file permissions, you may want to review the notes in the article Moving an Installation of mojoPortal to a Different Machine, there are some old temporary files that you could delete that may help.

Other than that you should try to reset the file system permissions for /Data and /App_Data, clearly if nothing is being logged then the log file is not writable. You could delete the currentlog.config file and if folder permissions are right it will come back on its own. Probably best to remove permissions first then re-add them and make sure it is set to propagate permissions to all child folders and files. 

Hope that helps,


5/8/2011 10:10:35 AM
Total Posts 31

Re: Upgrade with multi-site problem

Joe, Thanks for the quick reply. Turns out it was an IIS host header problem, not a permission problem. The updated version of mojo is looking great! Keep up the good work. mojo is one solid foundation for a website. I have about 6 sites using it so far, now i need to upgrade 2 other installs to the latest version. I will be buying you a beer for sure. Chris
You must sign in to post in the forums. This thread is closed to new posts.