SMTP Exchange Server Email Settings

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
12/3/2010 6:29:46 PM
Gravatar
Total Posts 2

SMTP Exchange Server Email Settings

Hello,

I have read the page on emailconfiguration and followed all instructions.

<add key="SMTPServer" value="exchange.server.com" />
<add key="SMTPRequiresAuthentication" value="true" />
<add key="SMTPUseSsl" value="true" />
<add key="SMTPPort" value="25" />
<add key="SMTPUser" value="myUser />
<add key="SMTPPassword" value="myPass" />

<smtp from="myUser@server.com">
<network
host="exchange.server.com"
port="25"
userName="myUser"
password="myPass"
defaultCredentials="false" />
</smtp>

The site works properly when e-mailing users in the event of a password reset using the smtp settings so I know my credentials and mail server are working properly. When it fails to work is when using the contact form widget on the site.

Any help would be greatly appreciated.

12/3/2010 10:13:18 PM
Gravatar
Total Posts 1991

Re: SMTP Exchange Server Email Settings

Hi Justin,

Have you set the "Site Email From Address" setting in Site Settings?

You can also check the SMTP log in Exchange to for the SMTP conversation after submitting the Contact Form.

HTH,
Joe D.

12/4/2010 7:12:32 AM
Gravatar
Total Posts 18444

Re: SMTP Exchange Server Email Settings

Make sure also that you have actually specified an email address to receive the notification in the contact form settings.

Best,

Joe

12/7/2010 1:29:00 PM
Gravatar
Total Posts 2

Re: SMTP Exchange Server Email Settings

@Joe Davis

I do have a site email from address setup.

This is the error from the log:

System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender
at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at mojoPortal.Net.Email.SendEmailNormal(SmtpSettings smtpSettings, String from, String replyTo, String to, String cc, String bcc, String subject, String messageBody, Boolean html, String priority, String[] attachmentPaths, String[] attachmentNames)

I have seen this error before when programming custom ASP.Net websites to work with exchange. I have to set default credentials to false in the network section of the stmp mail settings. Is there a way to do this in the "site email" settings.

@Joe Audette

I have specified this too.

To give you more information the server used to allow open relay. When this was up and running  the sites email worked great. They have since locked that away and the email failed in both site email and smtp. After switching to use authentication in the smtp settings section the password resets work and will send a valid email. In order to do that I had to set defaultCredentials to be false. Is there a way to do this in the site email settings?

 

Thanks for the help

Justin

12/7/2010 3:09:19 PM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: SMTP Exchange Server Email Settings

Hi there, in Administration, Site Settings, be sure that the "Site Email From Address" field is specified to use address within the domain that your Exchange server is serving. This setting might have defaulted to "noreply@mojoportal.com" and whatever is here overrides the setting in web.config/user.config.

Also, if you are using contact forms, be sure that the "Use entered email as from address" checkbox is unchecked for them. Since your server is doing strict domain checking, SMTP from contact forms set like that will fail too.

Jamie

You must sign in to post in the forums. This thread is closed to new posts.