About to pull my hair out.....

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
4/8/2010 12:22:05 PM
Gravatar
Total Posts 2

About to pull my hair out.....

Windows Server 2008

MS SQL Server 2008

latest version of mojoPortal

 

I have tried for 2 days now to get the configuration string working for connection.

 

I can connect from numerous other applications and websites to my local database and yet, from here, I can't.

 

I started the journey trying through the MS Web Deploy.

I put in a new UserID and password I had just created.

That didn't work.

I tried it again.

Still didnt' work.

I checked and rechecked the password, the server name, etc.

 

Finally, gave up on the web deploy install as it just wasn't going to work to save it's life.

Went the direct install route.

 

<add key="MSSQLConnectionString" value="Data Source=maincomputer;Initial Catalog=mojoportal;Integrated Security=True" />

<add key="MSSQLConnectionString" value="server=maincomputer;UID=mojoPortaluser;PWD=mojo123;database=mojoportal" />

 

<add key="MSSQLConnectionString" value="server=maincomputer\MSSQLSERVER;UID=mojoPortaluser;PWD=mojo123;database=mojoportal" />

And about 20 other variants.

 

All fail.

 

Probing system...
File system permissions ok.

The system cannot connect to the MSSQL database. Please check your connection string.


System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 25 - Connection string is not valid) at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject) at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection) at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory) at System.Data.SqlClient.SqlConnection.Open() at mojoPortal.Data.DBPortal.DatabaseHelperGetConnectionError(String overrideConnectionInfo)

Note: This page shows some information that is helpful during setup and upgrades but for security it would be best not to show any information when the system is up to date. You can disable setup and suppress all information on this page by setting DisableSetup=true in Web.config. When you need to upgrade, you can set this back to false. If you are logged in as Administrator setup will run and you will be able to see this page even if it is disabled in Web.config so you can easily leave it disabled and just login before upgrading. But if you are not logged in you will need to enable setup in Web.config.
 

HELP!!!!

4/8/2010 12:42:09 PM
Gravatar
Total Posts 18444

Re: About to pull my hair out.....

Hi,

Are you editing the Web.config or user.config?

If user.config exists you must edit it the connection string there as it takes precedence over Web.config, so if user.config is present it does not see the different tries you made with Web.config

However, ASP.NET does not auto detect changes in user.config so if you edit there you must touch Web.config to make it reload settings, ie type a space in it and save it.

If the WebDeploy method worked it would have created a user.config file, otherwise it would not exist unless you manualy rename the user.config.sample file to user.config

Most common problem with the web deploy approach is that it enforces the default password requirements of SQL Express even if you are not using the default password requirements. So it wants a password with at least 1 upper case, one lower case one number and one special char and some minimum length I can't remember off the top of my head. The password $Secret123 meets the criteria.

Hope it helps,

Joe

4/8/2010 1:21:10 PM
Gravatar
Total Posts 2

Re: About to pull my hair out.....

All it was was touching the web.config.

 

Sheesh.

 

You must sign in to post in the forums. This thread is closed to new posts.