File Manager problem

mojoPortal is no longer supported on mono. This forum is here for archival purposes.

This forum is for any topic related to running mojoPortal on GNU/Linux or Mac using Mono.

Anyone who can help with testing mojoPortal 2.x on Linux with Mono to find the bugs and report to the Mono team, this will help a lot. See the instructions for building with MonoDevelop.

This thread is closed to new posts. You must sign in to post in the forums.
12/21/2009 7:12:05 AM
Gravatar
Total Posts 10

File Manager problem

Centos 5.2

Apache 2.2.3

Mono 2.6.1

mojoportal 2.3.3

Administration - File Manager

When clicked on File Manager, following error appear:

Object reference not set to an instance of an object

Description: HTTP 500. Error processing request.

Stack Trace:

System.NullReferenceException: Object reference not set to an instance of an object
at mojoPortal.Web.AdminUI.FileManagerPage.ShowFileManager () [0x00000] in <filename unknown>:0
at mojoPortal.Web.AdminUI.FileManagerPage.Page_Load (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
at (wrapper delegate-invoke) System.EventHandler:invoke_void__this___object_EventArgs (object,System.EventArgs)
at System.Web.UI.Control.OnLoad (System.EventArgs e) [0x00000] in <filename unknown>:0
at mojoPortal.Web.mojoBasePage.OnLoad (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Web.UI.Control.LoadRecursive () [0x00000] in <filename unknown>:0
at System.Web.UI.Page.ProcessLoad () [0x00000] in <filename unknown>:0
at System.Web.UI.Page.ProcessPostData () [0x00000] in <filename unknown>:0
at System.Web.UI.Page.InternalProcessRequest () [0x00000] in <filename unknown>:0
at System.Web.UI.Page.ProcessRequest (System.Web.HttpContext context) [0x00000] in <filename unknown>:0

Version information: Mono Runtime Version: 2.6.1 (tarball Sun Dec 20 07:18:49 SGT 2009); ASP.NET Version: 2.0.50727.1433

Is this a mojoportal or mono bug?


Downloaded Mono 2.6.1 Virtual PC SuSE image.  Ran the mojoportal web framework.  Same error with the File Manager.

12/31/2009 8:12:45 AM
Gravatar
Total Posts 18444

Re: File Manager problem

Hi,

It seems to be Mono bugs, I was able to produce the same problem. The null reference seems to be that Mono does not find the progressbar controls in the page. I implemented a workaround and managed to get the page to load but then when I try to use the file manager like click to go to a folder and it blows up with more errors.

Seems to be some major bugs still in Mono.

Best,

Joe

You must sign in to post in the forums. This thread is closed to new posts.