Gallery content causes "Ah Shucks!" to display

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
8/1/2022 4:08:03 PM
Gravatar
Total Posts 3

Gallery content causes "Ah Shucks!" to display

I have been using the Image Gallery (Simple Folder Version) for several years to display about 150 small images.  This was IIS on Server 2016.

I built a new web server - Server 2022, latest IIS, DotNET, and MojoPortal. New SQL server as well, latest versions of all components for MS SQL (separate server). Using the default skin for now while getting things set up.

I copied the website folder to the new web server, backed up the SQL DB and restored it on the new SQL server. Performed the standard configuration/migration steps. When I launched the website, everything looked great - until - I selected the page with the image gallery, which displayed the Aw Shucks error. This page had HTML and 3 Gallery objects in the center pane. After removing the Gallery objects, the page would load. Adding the Image Gallery to the page but it fails to add any images whether individually or in bulk. Adding either the "Better Image Gallery" or the "Image Gallery (Simple Folder Version)" immediately displays the Aw Shucks error page with no opportunity to configure or try adding images.

I verified that the folder is writable by the IIS process App Pool. Not sure what is causing this but none of the Gallery objects are working. Appreciate any thoughts / insight you might offer.

8/2/2022 9:09:49 AM
Gravatar
Total Posts 2241

Re: Gallery content causes "Ah Shucks!" to display

Hi,

Can you take a look at your System Log (Administration > System Log)? It will give you details about the problem. Post the details here and we'll do our best to help. 

You may want to clear the log, cause the error, and then check the log again so you don't have any clutter to sift through.

Thanks,
Joe

8/9/2022 6:44:56 PM
Gravatar
Total Posts 3

Re: Gallery content causes "Ah Shucks!" to display

So - about that.. 

The log stops at:
2022-06-08 18:21:11,445 INFO (null) - (null) - (null) - mojoPortal.Web.Global - Global.asax.cs Application_End

That's 60-days ago. I can export the log, click Refresh and be brought back to the top (2021-04-03 date), but cannot Clear the log. The log is about 540KB in size, so that doesn't seem unreasonable or too large to clear quickly. (despite being an IT guy with zero patience, I did wait several minutes after clicking Clear Log before refreshing!)

I just created a new sub-page, added HTML content and the Image Gallery (Simple Folder Version) to the Center panel. Click View Page and I get the error message, with no updates in the log. Does this possibly point to a permissions issue? Can I force-clear the log? I do have direct access to both SQL and the web server.

I had not been actively running the site when I recovered the old Hyper-V host. Log dates jump from 2021-07-26 when I shut the servers down to 2022-05-28 when I started bringing guests online to verify operation and plan the migration. 06/08 is probably when I shut down services so I could copy content and backup/restore SQL to the new server(s). The new server shows 6/18 dates on most of the folders but the expected older timestamps on files.

8/10/2022 10:21:55 AM
Gravatar
Total Posts 3

Re: Gallery content causes "Ah Shucks!" to display

Follow-up to last message - when I go to the /test page from the web server itself, it displays a detailed error message which does point to either access denied or reporting that issue because the file path it referenced isn't there. Here's a link to the screenshot of the error, the physical folder path in Explorer, and the permissions (App Pool account has Modify rights) Gallery Error Message

8/11/2022 9:51:44 AM
Gravatar
Total Posts 2241

Re: Gallery content causes "Ah Shucks!" to display

Hi,

From within IIS:

  1. Select your site
  2. Under the IIS header on the site's properties page, open "Authentication"
  3. Click the "Anonymous Authentication" item
  4. Click the "Edit" link in the Actions pane.
  5. Ensure "Application pool identity" is chosen.

If that is set already, you need to double-check your permissions. Not being able to clear the log is always a permissions issue. IIS defaults websites to use the "IUSR" user as the anonymous identity but when we harden our servers, as we should, by setting the folder/file permissions to use the Application Pool Identity, things like this can break.

Hope this helps,
Joe

You must sign in to post in the forums. This thread is closed to new posts.