Handler Not yet determined

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

7/3/2017 11:31:00 PM
Gravatar
Total Posts 13
Ramesh Menta

Handler Not yet determined

Hi,

 

I have struck in installation of mojoportal with following error.

"This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false"."

however the same is running with visual studio when i debug.

I have gone through google search results such as making windows athentications, changing override to true in applicationpool.config etc but none is working for me.

If i run the same application in windows 8.1, it is working but i wanted to host mojoportal in windows 10 platform. Please advise.

OS: windows 10 64 bit

IIS 10

Dot Net 4

mojo version: MSSQL 2.5.0.0

7/5/2017 10:14:32 AM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Handler Not yet determined

It sounds like you need to make an adjustment in IIS settings. See this StackOverflow thread for an example of what you may need to do--the actual change to make will depend on which section of the web.config it's complaining about.

7/6/2017 2:23:10 AM
Gravatar
Total Posts 13
Ramesh Menta

Re: Handler Not yet determined

Hi,

Thanks for your suggestion, I have followed following steps from provided link.

1) In the connections tree (in IIS), go to your server node and then to your website.

2) For the website, in the right window you will see configuration editor under Management.

3) Double click on the configuration editor.

4) In the window that opens, on top you will find a drop down for sections. Choose "system.webServer/handlers" from the drop down.

5) On the right side, there is another drop down. Choose "ApplicationHost.Config "

6) On the right most pane, you will find "Unlock Section" under "Section" heading. Click on that.

7) Once the handlers at the applicationHost is unlocked, your website should run fine.

Now, the following error started…

1016:       <modules runAllManagedModulesForAllRequests="true">

 

I made it as ‘false’ under web.config at line 1016 but still same error exists

So repeated above steps and unlocked modules and set value to true

Here, I tried both the ways by setting value to false as well as true but error is same

Also tried as

<modules runAllManagedModulesForAllRequests="true" runManagedModulesForWebDavRequests="true">
Identity: ApplicationPoolIdentity
Identity: NetworkService

Now the error is as follows…

HTTP Error 500.21 - Internal Server Error

Handler "ExtensionlessUrlHandler-Integrated-4.0" has a bad module "ManagedPipelineHandler" in its module list

  • As stated in below link - 500.21 - Module not recognized.

https://support.microsoft.com/en-us/help/943891/the-http-status-code-in-iis-7.0,-iis-7.5,-and-iis-8.0

 But when i changed to Managaged Pipeline Mode to Clasic, in .Net Ver 4.0, the error is as

HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

_________________________________________________________________________________________________________________________

When I changed dot net version to .Net 2
Error is as follows (Both in Integrated and Classic in Managed Pipeline)

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.

Config Error

The configuration section 'system.web.extensions' cannot be read because it is missing a section declaration


 

Kindly help me out.. 

7/6/2017 3:17:09 AM
Gravatar
Total Posts 13
Ramesh Menta

Re: Handler Not yet determined

Hi,

Finally, the problem is solved by running below command.

1. Run command prompt as administrator

2. run the command "dism /online /enable-feature /featurename:IIS-ASPNET45 /all"

It will install two ApplicationPoolIdentities

.Net v4.5

.Net v4.5 Classic

My site is under NetworkService, .Net v4.0, Integrated, NetworkService.

Thanks mojo smileysmileyyes

7/6/2017 11:25:50 AM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: Handler Not yet determined

I'm glad you figured it out. mojoPortal does require an ASP.NET 4 or higher application pool.