DisableAutoCompleteOnLogin not working?

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
7/14/2015 12:55:57 PM
Gravatar
Total Posts 115

DisableAutoCompleteOnLogin not working?

As a pen test highlighted the same issue as this thread https://www.mojoportal.com/Forums/Thread.aspx?pageid=5&t=11623~1 I tried out the promised setting

<add key="DisableAutoCompleteOnLogin" value="true"/>

but it doesn't appear to make any difference.

?

7/14/2015 1:09:21 PM
Gravatar
Total Posts 18444

Re: DisableAutoCompleteOnLogin not working?

that setting will make it add autocomplete="off" on the input, so it does what it is supposed to.

Whether web browsers respect it is a separate issue, in fact Chrome is willfully disrespectful of the intentions of the web developer on this issue.

7/14/2015 1:31:08 PM
Gravatar
Total Posts 115

Re: DisableAutoCompleteOnLogin not working?

that's what I was expecting, but in fact I get this on /secure/login.aspx...

<input name="ctl00$mainContent$login1$LoginCtrl$Password" type="password" id="ctl00_mainContent_login1_LoginCtrl_Password" class="normaltextbox passwordbox" />

I'm using latest mojoPortal version 2.4.0.9

 

7/14/2015 1:50:22 PM
Gravatar
Total Posts 18444

Re: DisableAutoCompleteOnLogin not working?

it works testing on my machine with the latest code, as far as I know it has been there for quite a while

7/16/2015 3:57:41 PM
Gravatar
Total Posts 115

Re: DisableAutoCompleteOnLogin not working?

I have tried on another 2.4.0.9 site and the setting had no effect. I'll try it in dev environment when I get a chance.

7/17/2015 3:21:39 PM
Gravatar
Total Posts 115

Re: DisableAutoCompleteOnLogin not working?

This is working fine in my development system - no idea why it doesn't seem to work in production sites, but I'll post if I find out.

7/17/2015 3:28:45 PM
Gravatar
Total Posts 18444

Re: DisableAutoCompleteOnLogin not working?

look to see if the config setting exists in more than one place, if it does the one lower in the file wins, user.config is "lower" than Web.config so user.config wins over web.config but it could be in user.config more than once and the bottom one wins

7/17/2015 3:57:30 PM
Gravatar
Total Posts 115

Re: DisableAutoCompleteOnLogin not working?

only one instance of the setting. Now upgrading site to the latest codebase and will try again.

7/17/2015 4:47:03 PM
Gravatar
Total Posts 115

Re: DisableAutoCompleteOnLogin not working?

yay, now working after upgrading site to latest pull of source code (2.4.0.9 plus...). The version of mojoportal.web.dll I upgraded from dated to 03 January 2015.

You must sign in to post in the forums. This thread is closed to new posts.