Page Security Issue

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
6/30/2015 7:50:57 AM
Gravatar
Total Posts 27

Page Security Issue

I have populated my users, roles and pages through a code. So everything was created programmatically. The security of the pages was also set by code. I have specified which roles have access to specific pages. The problem is that the page security is not working properly. If a user logs in for the first time, he only has access to the pages that his role has permission to. Once he clicks on any link on the page ( any post back action occurs ) the security will break and he will see all the pages, although he doesn't have permission to view. I have noticed that if me, as Administrator, just go to the page security and click on save, the user will not be able to access the page that I have just saved the security for.

 

Any advice ?

 

Best.

7/1/2015 8:09:32 PM
Gravatar
Total Posts 1991

Re: Page Security Issue

Do you have any errors in the log?

Are you sure your code is creating the users, roles and pages properly?

Thanks,
Joe

7/2/2015 8:11:51 AM
Gravatar
Total Posts 27

Re: Page Security Issue

Dear Joe,

 

Thanks a lot for your reply.

 

I found the problem, it was because of a space next to the role name in AuthorizedRoles field in pages table.

 

Best.

You must sign in to post in the forums. This thread is closed to new posts.