Enable 32-bit on application pool on Server 2012?

Post here for help with installing or upgrading mojoPortal pre-compiled release packages. When posting in this forum, please provide all relevant details. You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

Post here for help with installation of mojoPortal pre-compiled release packages

When posting in this forum, please try to provide as many relevant details as possible. Particularly the following:

  • What operating system were you running when the bug appeared?
  • What database platform is your site using?
  • What version of mojoPortal are you running?
  • What version of .NET do you use?
  • What steps are necessary to reproduce the issue? Compare expected results vs actual results.

You may also want to review the installation or upgrading documentation.

If you have questions about using the source code or working with mojoPortal in Visual Studio, please post in the Developer forum.

This thread is closed to new posts. You must sign in to post in the forums.
1/6/2015 8:50:32 AM
Gravatar
Total Posts 503
feet planted firmly on the ground

Enable 32-bit on application pool on Server 2012?

I have a mojoPortal site on Arvixe on a 64-bit Windows 2012 Server. It's running mojoPortal 2.4.0.8.  After having bother with one of my custom components which talks to an MDB, I asked Arvixe support to enable 32-bit applications in the application pool. (This is something we cannot get at through the normal web interface so they have to do it.)

Each time they do this, they come back to me saying the site is working fine, but I find it is broken and giving HTTP 500 server internal error. They then acknowledge it is broken and set it back again.

I don't have a Server 2012 with a mojoPortal site to cross-check, but I do have Server 2008 R2 64-bit servers, and on those, enabling 32-bit applications in the application pool has no effect on mojoPortal - the site keeps working fine.

I can't help thinking the Arvixe guys are doing something strange, but before pushing this, can anyone confirm whether a mojoPortal 2.4.0.8 should be able to operate fine on Windows 2012 Server 64-bit with the application pool set to enable 32-bit applications?

thanks!

1/6/2015 9:10:29 AM
Gravatar
Total Posts 18444

Re: Enable 32-bit on application pool on Server 2012?

I would not expect that to matter. I can say that on my local win 8 machine where I work on mojoportal I have 32 bit enabled on the app pool because it is needed in order to test sqlite because the unmanaged sqlite dll is 32 bit. I have never had any problem with it and I never disable it when not testing sqlite, I just leave it enabled all the time.

But I do recall seeing forum posts in the past where people were getting strange errors and they said they resolved it by disabling 32 bit on the app pool which surprised me. So I guess in some cases it may be problematic but I have no idea why or what specifically can make it problematic since it has never been problematic for me. 

1/6/2015 1:47:22 PM
Gravatar
Total Posts 115

Re: Enable 32-bit on application pool on Server 2012?

Thanks Joe, I'll try Arvixe one more time...

1/7/2015 2:11:21 AM
Gravatar
Total Posts 115

Re: Enable 32-bit on application pool on Server 2012?

Same happened again. Arvixe enabled 32-bit, and came back to me saying the site was working fine (and I had specifically asked them to restart the site and app pool and then test that the site was working). Two minutes later I received notification that the site was down. I could only check it on my phone, but the home page of my site was showing compiler errors (verbose errors had been switched on for the site). I asked Arvixe to revert the change, which they did, and the site came back.

I didn't capture exact details of the compiler errors this time. But I am puzzled how Arvixe could test and say the site was working, only for it to go down moments later with no further changes being made.

I have previously experienced similar compiler errors on the same server after making minor changes in user.config/web.config that were resolved by removing and replacing the /bin folder (to force complete recompilation).  The errors I saw that time were like this "Compiler Error Message: CS0433: The type 'ASP.controls_metacontent_ascx' exists in both 'c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\e3cf2397\7b5165fc\App_Web_bci0xhcz.dll' and 'c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\e3cf2397\7b5165fc\App_Web_m4u4hg3p.dll'"

I think my next step is to set up a virtual Server 2012 and test this out for myself, but that will take some time. Any thoughts/advice appreciated.

1/7/2015 7:49:13 AM
Gravatar
Total Posts 18444

Re: Enable 32-bit on application pool on Server 2012?

That is the kind of error that I recall someone saying that they solved by changing that setting.

Myself when I see an error like that in the temporary aspnet files, I think the aspnet compiler got a little hosed up and compiled something in 2 places. The way I would try to solve that error is to stop the web site in IIS and delete the folder containing the temporary files

'c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\e3cf2397\7b5165fc\'

that would give aspnet compiler the chance to recompile again and correct itself.

you can't delete the folder/files while they are in use which is why the site must be stopped in IIS to do it.

then if the problem returns I guess I would have to blame that setting, but I would try to solve it first without changing that.

1/18/2015 2:44:41 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: Enable 32-bit on application pool on Server 2012?

Just a note to confirm that I have tested on a virtual Windows Server 2012 Standard (running on VirtualBox) with mojoPortal 2.4.0.8, and found that enabling 32-bit applications on the application pool is fine. I can switch this on and off at will and the site keeps running with no problems.

So I've no idea what's been happening on the Arvixe servers, but sometimes I think their engineers try to be too helpful - after the last attempt when I simply asked them to make the change and stop/start the site, I found that my /bin folder no longer contained sts.MobileKit.Web.dll, so the site bombed on mobile. I can only assume Arvixe had replaced my /bin folder with one from a default mojoPortal download.

I've still not solved how to talk to an MDB though!

 

 

1/18/2015 4:11:16 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: Enable 32-bit on application pool on Server 2012?

Solved. It’s perfectly possible to use an MDB/ACCDB database in ASP.Net on Server 2012 64-bit, but you do need this driver installed on the server:

Microsoft Access Database Engine 2010 Redistributable

http://www.microsoft.com/en-gb/download/details.aspx?id=13255

And, if the 32-bit version of this driver was installed you will also need to enable 32-bit applications on the Application Pool. If you install the 64-bit version (AccessDatabaseEngine_x64.exe) then you don't.

2/1/2015 2:32:01 PM
Gravatar
Total Posts 503
feet planted firmly on the ground

Re: Enable 32-bit on application pool on Server 2012?

In case anyone else hits the same issues, this is not fully resolved after all.

On my local virtualised Windows 2012 Server I can run my site with 32-bit enabled, no problem. But on the Arvixe server this just won't work - compiler errors every time, even with clearing out the .Net temp files etc.  I don't know what the difference is with their environment.

And because Arvixe are only prepared to install the 32-bit version of the Microsoft Access Database Engine 2010 Redistributable (you can't have both versions on one machine apparently), I'm left unable to connect my component to its MDB/ACCDB. Time to move the data into another store I think.

You must sign in to post in the forums. This thread is closed to new posts.