Favicon showing up only on https pages

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
11/27/2014 3:00:29 AM
Gravatar
Total Posts 36

Favicon showing up only on https pages

Hi,

I am facing an issue. I have favicon in my skin folder and I have cleared my browser cache but favicon is not showing up. I can see favicons only on https pages like login and register and rest all the pages does not show favicon. This issue is in IE 11. It works fine in Chrome and FF.

I am using mojoPortal version 2.3.9.7. Could you please let me know why I am facing this issue.

Thanks,

Mahua Banerjee

11/27/2014 6:14:45 AM
Gravatar
Total Posts 36

Re: Favicon showing up only on https pages

Hi,

I searched for the solution but solution seems to work only for interior page. When I click on home page favicon is still not displayed.

I added this in web.config

<location path="Data/Sites/1/skins/FTHome2013/favicon.ico">

<system.web>

<authorization>

<allow users="*" />

</authorization>

</system.web>

</location>-->

<location path="Data/Sites/1/skins/FTInterior2013/favicon.ico">

<system.web>

<authorization>

<allow users="*" />

</authorization>

</system.web>

</location>

Thanks,

Mahua

11/27/2014 6:59:36 AM
Gravatar
Total Posts 1991

Re: Favicon showing up only on https pages

You shouldn't need to add anything to your web.config for the favicon.

I assume you have cleared your cache in IE? Have you tried pressing Ctrl-F5 in IE to force IE to reload the site? Maybe try changing the skin version guid in Administration > Advanced Tools > Design Tools > Cache Settings.

Also, I moved this thread to the "Help with Design and Skins" forum as it isn't really development related.

HTH,
Joe D.

11/27/2014 11:18:19 PM
Gravatar
Total Posts 36

Re: Favicon showing up only on https pages

Thanks it worked after resetting the GUID from administration-> advanced tools-> design tools -> cache tool -> Click on "RESET SKIN VERSION GUID"

11/28/2014 3:32:19 AM
Gravatar
Total Posts 36

Re: Favicon showing up only on https pages

Hi,

Issue is still not resolved completely. I have removed the changes from .config as per your suggestion and did what you suggested below and it worked fine. But it is failing in these scenarios.

1. If we restart the website from IIS then again favicon is not visible.

2. I did the steps mentioned below for IE 11 but when I checked for IE 10 then it was not working.

Could you please let me know why it is happening so.

Thanks,

Mahua

 

11/28/2014 9:25:52 AM
Gravatar
Total Posts 1991

Re: Favicon showing up only on https pages

Favicons are cached rather heavily by the browsers, especially IE. If you have managed to see the correct icon in most browsers, including IE 11, the server is configured properly.

As for the wrong icon showing up after restarting the website in IIS, that's very odd and I have no advice for you about that problem.

The only thing left you could try is to make sure there is no favicon.ico file in the root of the site or, if there is, it is the correct one.

Thanks,
Joe D.

12/1/2014 3:54:58 AM
Gravatar
Total Posts 36

Re: Favicon showing up only on https pages

 

Hi Joe,


Thanks for your help.


Yes I am able to see favicon in most of the browser but problem is with IE. I have tried all possible solution like verifying if this tag is present or not but no luck.


<meta http-equiv="X-UA-Compatible" content="IE=edge" />


Even on IE 11 when I do not restart the website from IIS and browse my site sometimes favicon is loaded first time but sometime I have to reload that that page and then favicon is loaded. Not sure why it is happening like this. And this is random and does not happen always.

 

You must sign in to post in the forums. This thread is closed to new posts.