Internet Explorer Compatibility View Printable View

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
7/9/2014 10:45:23 PM
Gravatar
Total Posts 32

Internet Explorer Compatibility View Printable View

Hi Joe

We are using MP for our intranet. We have enforced a Group Policy setting to turn off "Display intranet sites in Compatibility View" so that it would display correctly. Unfortunately, when I click on the Printable View the page will not load correctly, ie I lose the scroll bars. I also lose the scroll bars when viewing it in Chrome but I can still use the mouse to scroll, I can't do this in IE. IE is our company's standard browser so switching to Chrome isn't an option.

Do you know if there is any code I can add to the printerfriendly skin layout.master or any of the CSS files to force Compatibility View for Printable View?

Thanks
Sandy

7/10/2014 10:43:55 AM
Gravatar
Total Posts 1991

Re: Internet Explorer Compatibility View Printable View

Hi Sandy,

The Printable View skin is very basic so you shouldn't need to force compatibility view on it. Instead, figure out why it's not working correctly in IE and fix the issue. Compatibility View should always be used as a very last resort.

The problem is probably with and overflow: hidden rule in the CSS somewhere. Without seeing your site, it's hard to tell though. Best thing to do is open the site in IE, view the printable view and then open the IE Dev Tools by pressing F12 on your keyboard. Use the Element Select tool to select the page and then start looking through the CSS style listed on the right for anything that may be causing the scrollbars to not show up. If you don't see anything, start selecting different elements in the markup on the left and then check the styles associated with those elements. Once you find the culprit, make note of it and then remove it from the printerfriendly skin inside of \data\sites\[n]\skins\printerfriendly.

If you have trouble with that, and you're using a relatively new version of mojoPortal 2.4.x.x or higher, copy the printerfriendly skin from \data\skins to data\sites\[n]\skins. Now you'll be using the latest version of the skin so maybe that'll fix the problem.

Also, if you're using IE 8 or older, you really just need to upgrade. Even if you're using IE 9, you should upgrade. I know the corporate world doesn't like to upgrade IE but they never treat the other browsers that way and they should just get over it. :-) /end rant.

HTH,
Joe D.

7/10/2014 6:16:27 PM
Gravatar
Total Posts 32

Re: Internet Explorer Compatibility View Printable View

Thanks for your comprehensive reply Joe.

I'm "special" so I have installed Chrome on my computer, for development and troubleshooting purposes ;). I did in fact find a hidden overflow rule when inspecting the page.

I rectified this by your second option of copying the newer printerfriendly skin into my site skins. Then I just had to match the font styles in the styleprinter.css and style.css within that skin, there was a mismatch between Arial and Times New Roman between the body and headings.

So this issue has been resolved. Thanks once again for your assistance. Happy to read your rants in exchange for help.

Kind regards, Sandy 

You must sign in to post in the forums. This thread is closed to new posts.