Nofollow in feed manager

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
6/9/2014 6:17:54 AM
Nik
Gravatar
Total Posts 36
mojoportal.net.ua - Russian community of mojoportal

Nofollow in feed manager

Good day. 

Is it possible to add for all external links rel=nofollow in the feed manager?

6/10/2014 11:31:46 AM
Nik
Gravatar
Total Posts 36
mojoportal.net.ua - Russian community of mojoportal

Re: Nofollow in feed manager

I found how to hide some links (in the file /FeedManager/FeedManagerModule.ascx):

1. feedsitelink

<asp:HyperLink ID="lnkItem"  runat="server" CssClass='<%# "feedsitelink lnk" + Eval("ItemID")%>' EnableViewState="false" Visible="<%# LinkToAuthorSite %>" 
                                        NavigateUrl='<%# Eval("Url")%>'><%# DataBinder.Eval(Container, "DataItem.Author")%>
                                    </asp:HyperLink>

changed to 

<asp:HyperLink ID="lnkItem" rel="nofollow" runat="server" CssClass='<%# "feedsitelink lnk" + Eval("ItemID")%>' EnableViewState="false" Visible="<%# LinkToAuthorSite %>" 
                                        NavigateUrl='<%# Eval("Url")%>'><%# DataBinder.Eval(Container, "DataItem.Author")%>
                                    </asp:HyperLink>

2. rssfeedname before content

<asp:HyperLink ID="Hyperlink6" runat="server" EnableViewState="false" NavigateUrl='<%# DataBinder.Eval(Container, "DataItem.BlogUrl")%>'>
                                                <%# Server.HtmlEncode(DataBinder.Eval(Container, "DataItem.FeedName").ToString())%>
                                                    </asp:HyperLink>

changed to

<asp:HyperLink rel="nofollow" ID="Hyperlink6" runat="server" EnableViewState="false" NavigateUrl='<%# DataBinder.Eval(Container, "DataItem.BlogUrl")%>'>
                                                <%# Server.HtmlEncode(DataBinder.Eval(Container, "DataItem.FeedName").ToString())%>
                                                    </asp:HyperLink>

3. rssauthor

<asp:HyperLink ID="Hyperlink1" runat="server" EnableViewState="false" NavigateUrl='<%# DataBinder.Eval(Container, "DataItem.BlogUrl")%>'>
                                                <%# Server.HtmlEncode(DataBinder.Eval(Container, "DataItem.Author").ToString())%>
                                                    </asp:HyperLink>

changed to

<asp:HyperLink rel="nofollow" ID="Hyperlink1" runat="server" EnableViewState="false" NavigateUrl='<%# DataBinder.Eval(Container, "DataItem.BlogUrl")%>'>
                                                <%# Server.HtmlEncode(DataBinder.Eval(Container, "DataItem.Author").ToString())%>
                                                    </asp:HyperLink>

4. rssfeedname

<asp:HyperLink ID="Hyperlink5" runat="server" EnableViewState="false" NavigateUrl='<%# DataBinder.Eval(Container, "DataItem.BlogUrl")%>'>
                                                <%# Server.HtmlEncode(DataBinder.Eval(Container, "DataItem.FeedName").ToString())%>
                                                    </asp:HyperLink>

changed to

<asp:HyperLink ID="Hyperlink5" rel="nofollow" runat="server" EnableViewState="false" NavigateUrl='<%# DataBinder.Eval(Container, "DataItem.BlogUrl")%>'>
                                                <%# Server.HtmlEncode(DataBinder.Eval(Container, "DataItem.FeedName").ToString())%>
                                                    </asp:HyperLink>

It's temporary decision. Because if you will update mojoportal, settings are not saved.

Unfortunately I can't find how to hide rsstitle

 

6/10/2014 11:32:53 AM
Gravatar
Total Posts 18444

Re: Nofollow in feed manager

Hi,

Currently by default if you have the setting checked in the Shared Files Security Settings:

"Filter Invalid Markup and Potentially Dangerous Content From Feeds?"

then NeatHtml is used to protect from the untrusted content and NeatHtml puts a nofollow on all links withing the content. However the heading which links to the original source article does not currently have a rel=nofollow.

I will add a FeedManagerDisplaySetting for the next release so you will be able to use UseNoFollowOnHeadingLinks="true" from theme.skin to force a nofollow there.

Hope that helps,

Joe

6/10/2014 11:43:01 AM
Nik
Gravatar
Total Posts 36
mojoportal.net.ua - Russian community of mojoportal

Re: Nofollow in feed manager

Thank You very much, Joe.

You must sign in to post in the forums. This thread is closed to new posts.