Homepage redirecting to the login page?

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
4/4/2014 6:36:42 PM
Gravatar
Total Posts 5

Homepage redirecting to the login page?

Hi everyone, here is the issue we're having.  If you go to the root of our site http://www.crackerjack-it.com it redirects to the login page.  I cannot for the life of my figure out what I have set wrong in admin.

Can anyone help out?

Thanks in advance,

Josh

4/7/2014 7:51:22 AM
Gravatar
Total Posts 18444

Re: Homepage redirecting to the login page?

Check the allowed view roles in page settings of the home page. If you don't have "All Users" allowed as view roles then un-authenticated users will be redirected to the login page. If they login and still are not in an allowed role then they will be redirected to the access denied page. So normally you would want the home page to allow all users and if you have protected content put that on other pages that won't be accessible until a user logs in.

Hope that helps,

Joe

4/7/2014 2:45:12 PM
Gravatar
Total Posts 5

Re: Homepage redirecting to the login page?

Hi Joe,

Thanks for the feedback.  I checked and my homepage is set to allow All Users view access.  The strange thing is that on my laptop where I developed the site it works perfectly but deployed to my server it's not working.  I am not seeing any code differences or anything so I'm not sure what's going on.

Thanks,

Josh

4/7/2014 2:50:50 PM
Gravatar
Total Posts 18444

Re: Homepage redirecting to the login page?

check the IIS settings and make sure anonymous authentication is the only thing enabled. Specifically make sure digest and basic authentication are disabled.

Hope that helps,

Joe

4/7/2014 2:58:29 PM
Gravatar
Total Posts 5

Re: Homepage redirecting to the login page?

The site is set to enable anonymous authentication.  It's also got forms authentication turned on but just to see what would happen, I turned it off.  Same problem but the local copy of the site has it on as well and it's working so no luck there.

Josh

4/7/2014 2:58:45 PM
Gravatar
Total Posts 18444

Re: Homepage redirecting to the login page?

what content features are on the home page? any custom features on there that might be redirecting?

I would check the settings for each content module to make sure they are not protected though the built in modules should not do any redirecting they would just be filtered out if a user is not in an allowed role

I tried other pages from your site map and they work ok so it seems to be something about the home page specifically. You might try temporarily moving a different page to the home position from Administration > Add/Edit Pages and see if it behaves differently.

4/7/2014 3:00:19 PM
Gravatar
Total Posts 1992

Re: Homepage redirecting to the login page?

Hi Josh,

If you have access to IIS Manager on the server, do the following:

  1. Select the site from the "Sites" list in the "Connections" pane on the left.
  2. Select "Authentication" from the "IIS" section in the "Features" view.
  3. Select "Anonymous Authentication" and then select "Edit" in the "Actions" pane on the right.
  4. Verify the "Anonymous user identity" has read access to the directory containing your site files.
    1. If "Specific user" is selected, you'll be checking for the user account listed.
    2. If "Application pool identity" is used, you'll more than likely be checking for a user account with the same username as the name of your application pool. For example, if your application pool is named "My Cool Website", the user account will be named "My Cool Website".
      • If this user doesn't exist on the site directory, you'll need to add it. To do so, add the user as you would any other user except you'll need to use "IIS AppPool\My Cool Website" as the username. Windows doesn't list these users so you'll need to type it and you have to use the "IIS AppPool\" prefix. Once you add the user the prefix disappears.
  5. Go back to the sites "Features" view and select "Basic Settings" under "Edit Site" in the "Actions" pane on the right.
  6. Click the "Connect as…" button and verify "Application user (pass-through authentication)" is selected.

Hope this helps,
Joe D.

4/7/2014 3:00:54 PM
Gravatar
Total Posts 18444

Re: Homepage redirecting to the login page?

actually it seems like the home page works with the url /home but not with /

make sure that Default.aspx is configured as the default document in IIS, remove any others from the list of default documents.

4/7/2014 3:06:40 PM
Gravatar
Total Posts 1992

Re: Homepage redirecting to the login page?

Hi Josh,

Well, looking at this again, I see you meant the homepage was the only page doing this. We've had this crop up before and people usually say homepage does it but then we figure out that all pages do it.

You might want to review what I wrote earlier but I don't think it's going to fix the problem in this case.

Default doc is probably your culprit.

Thanks,
Joe D.

4/7/2014 3:11:41 PM
Gravatar
Total Posts 5

Re: Homepage redirecting to the login page?

Hi Guys,

Joe D. pointed me in the right direction.  It appears that the folder permissions were changed when I "accidentally" ran the setup script again.  I reset the permission for the user account that the site runs under and it's back to normal.

Thanks both of you for the assistance.  I love this CMS.

Josh

4/7/2014 3:20:03 PM
Gravatar
Total Posts 18444

Re: Homepage redirecting to the login page?

Glad its working.

fyi the /Setup/Default.aspx page does not do anything with file system permissions, it is not capable of changing them at all. When files are uploaded from one machine to another though the permissions can be lost sometimes because each file has an "owner" sid and the owner sid from one machine is not recognized on another machine.

never fear to run the setup page though, it can never hurt anything

You must sign in to post in the forums. This thread is closed to new posts.