Turn off translation but keep localization settings

This is a place to discuss how to adapt mojoPortal to the needs of different cultures. Before asking questions here please first review the localization documentation.

This thread is closed to new posts. You must sign in to post in the forums.
6/3/2013 3:25:06 AM
Gravatar
Total Posts 23

Turn off translation but keep localization settings

Hi,

Is it possible to turn off the translation for a website but keep the users localization for time/dates conversions?

If i use the method described on: http://www.mojoportal.com/forcing-a-specific-language im afraid all settings for time/dates will be in the language i set, is this true?

Thanks,

 

 

6/3/2013 6:21:17 AM
Gravatar
Total Posts 18444

Re: Turn off translation but keep localization settings

Yes it is. See the article about forcing a specific language and note the difference between culture which is used for date and number formating and uiculture which determines which resx (language) files are used for labels and buttons.

Note also that if you are doing ecommerce ie using webstore you would not want it to be up to the users preference  because then prices may show in the wrong currency format.

But if you don't want to force a language and you do want it to adapt for some weird reason only numbers and dates then you would not force a language but just remove the auto: from the uiculture attribute on the gloabalization element in web.config

<globalization
            culture="auto:en-US"
            uiCulture="auto:en"
            requestEncoding="utf-8"
            responseEncoding="utf-8"
            fileEncoding="iso-8859-15" />

See also Localization

Hope that helps,

Joe

6/4/2013 9:30:04 AM
Gravatar
Total Posts 23

Re: Turn off translation but keep localization settings

Thanks Joe,

I found the page to force a language but that wasnt what i was looking for. The localization page gave me the answer, i removed the auto from uiculture to force a language but keep dates and numbers based on browser settings. Im not sure if you got it the other way around but this is what worked for me.

You must sign in to post in the forums. This thread is closed to new posts.