HTML Editor controls missing

A place for discussion about skinning and design. Before posting questions here you should review the documentation about creating skins.

This thread is closed to new posts. You must sign in to post in the forums.
4/17/2012 6:15:05 AM
Total Posts 76

HTML Editor controls missing


I desperately need help with the html editor in MojoPortal. I have several websites hosted on the same installation and Im facing this problem on one paticular site ie site id number 77.

The html editor displays only a few buttons. It does not display all the buttons on the toolbar.

Even the  "Source" button is missing. I have checked the web.config but if theres a problem with the web.config,then it shouldnt work for all the sites. But here it does not work for this paticular site.

I've tried :

  1. Changing the editor on the site settings under Administration but it has no effect. CKeditor is being used no matter what I set.
  2. Tried clearing cache after doing the above
  3. Checked the web.config for path of fckeditor,ckeditor and TinyMce.
  4. Checked on many other sites on the same installation...those sites work fine.
Currently I am managing disabling the WYSIWYG on the html settings. But the client needs the html editor. I'm using the latest version of MojoPortal. Just upgraded and ported everything last week. I think this problem started since then..

Please help.



4/17/2012 10:36:42 AM
Total Posts 76

Re: HTML Editor controls missing

4/17/2012 10:49:30 AM
Total Posts 18439

Re: HTML Editor controls missing

Are you sure you don't have the setting enabled in site settings that allows the user to choose his editor preference? Then it would use the setting from the user profile.

Do you get any script errors in the page?

Does changing the skin have any effect on the problem?

Are you using a custom config file for the editor?

4/17/2012 11:05:56 AM
Total Posts 76

Re: HTML Editor controls missing

Thanks for the users profile works now.

I have no idea why it didnt work. All I did was go to the users profile, changed the editor from site default to TinyMCE, It worked as TinyMCE

Then I changed it to CKEditor,it worked again as CKEditor. Then, I changed it back to site default and it works perfectly now as per whatever is specified in the site settings. I have no idea what went wrong and what caused it not to work before.

On the log, I just see this error repeated many times :

2012-04-17 19:22:50,284 ERROR (null) - (null) - (null) - mojoPortal.Business.WebHelpers.IndexWriterTask - System.IO.IOException: Lock obtain timed out: SimpleFSLock@C:\.....wwwroot\Data\Sites\1\index\write.lock
at Lucene.Net.Store.Lock.Obtain(Int64 lockWaitTimeout)
at Lucene.Net.Index.IndexReader.AquireWriteLock()
at Lucene.Net.Index.IndexReader.DeleteDocument(Int32 docNum)
at Lucene.Net.Index.IndexReader.DeleteDocuments(Term term)

The editor works now. Thank you Joe.

You must sign in to post in the forums. This thread is closed to new posts.