...some Questions,

If you have questions about using mojoPortal, you can post them here.

You may want to first review our site administration documentation to see if your question is answered there.

This thread is closed to new posts. You must sign in to post in the forums.
4/16/2012 9:45:20 AM
Gravatar
Total Posts 3

...some Questions,

Hello,

I have read all the documentation, but have not found an clear answer. So please allow some Questions: Smile

The situation first - I am testing a Folderbased, Related and two language website - so I have:

  1. WebSite - MyDomain.de - it has one page which offers the selection of the language - /de/ or /en/.
  2. WebSite - MyDomain.de/de/ - it has the Content in German
  3. WebSite - MyDomain.de/en/  - has the Content in English

If I create a Content Template in one the Sites, is it possible to make it automatically available in the other sites too? (like Users)

The main content will be pictures. The pictures itselfs are the same in EN and DE, only the Caption and Description will vary. Is there a way to have the pictures in a location that is accessable from the /de and the /en Site? (when using the Galleries in mojo). If not, I would have to upload all the pictures twice Undecided

How to activate the display of Exif Data for pictures - I saw the GalleryMetaData.xsl ?

I would like to offer a visitor, who is watching an English page, to switch to the same page which has the content in German and vise versa. I saw same request on the site, but I could not find an answer. Do I have to program it by myself, or is there a solution already?

EDITED: I forgot to mention. I am Logged in in mojoportal.com.But the site does not see that. When clicking Sign In, mojo recognizes that I am logged in and displays it. Is it a Bug? I think the site should see that I am Signed in, when approaching.

Thanks, Regards,

Rainer

4/16/2012 11:36:11 AM
Gravatar
Total Posts 1188
Proud member of the mojoPortal team

Help support mojoPortal!
Add-on modules

Re: ...some Questions,

I can't help you with the multilingual question, but about your signing in question, that is not a bug. In order to protect the role cookie data from being intercepted, it will only be delivered over an SSL connection. So if you come in under non-secured http mode, the site does not exchange the cookie and will not know you are signed in. As soon as you switch to SSL on the sign in page, the role cookie is exchanged and the site knows who you are.

So the best way to avoid this is to always visit your site using SSL mode when you are signed in with a persistent cookie.

There's more detail about this on the Use SSL documentation page.

Jamie

4/16/2012 11:45:41 AM
Gravatar
Total Posts 3

Re: ...some Questions,

Hi Jamie,

Yes - right - I see that now Smile

Thanks.

Rainer

4/16/2012 12:09:36 PM
Gravatar
Total Posts 18444

Re: ...some Questions,

Hi Rainer,

As a workaround for content templates you could alter the stored procedure mp_ContentTemplate_SelectAll so that it does not use the SiteGuid parameter and just brings back all templates for all sites.

If your sites use the same images and you have control of the server, a workaround would be to create folder /Data/commonmedia

Then copy all the files and folders from /Data/Sites/[SiteID]/media into the commonmedia folder

Then delete the media folder from each site under /Data/Sites/[SiteID]/

Then create an IIS virtual directory for each site at /Data/Sites/[SiteID]/media and make each virtual directory point to the /Data/commonmedia folder

That way all the sites have a media folder but they all really point to the same physical folder.

Hope that helps,

Joe

4/17/2012 6:03:53 AM
Gravatar
Total Posts 3

Re: ...some Questions,

Hi Joe,

"..alter the stored procedure mp_ContentTemplate_SelectAll so that it does not use the SiteGuid parameter".

Joe I did. In SQL Server when running the changed procedure the result was as expected. But in mojo there where only these templates listed that were defined for the specific site. AND the CKeditor did no longer displayed any ConterntTemplates.

So - I changed it back for now.

"...and make each virtual directory point to..."

The simplest solutions are the most genious one Laughing.

Best Regards,

Rainer

5/2/2012 2:08:57 AM
Gravatar
Total Posts 8

Re: ...some Questions,

Hello,

I just do the steps, like Joe explained. In the sites every thing works fine. I see the pictures I already used. 

But neither the file manager shows the media directory, even the dialogues for image upload / selection.

Any suggestions on what to do?

You must sign in to post in the forums. This thread is closed to new posts.