Using RAD Editor in mojoPortal

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

Please do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.

This forum is for discussing mojoPortal development

This forum is only for questions or discussions about working with the mojoPortal source code in Visual Studio, obtaining the source code from the repository, developing custom features, etc. If your question is not along these lines this is not the right forum. Please try to post your question in the appropriate forum.

You can monitor commits to the repository from this page. We also recommend developers to subscribe to email notifications in the developer forum as occasionally important things are announced.

Before posting questions here you might want to review the developer documentation.

Do not post questions about design, CSS, or skinning here. Use the Help With Skins Forum for those questions.
This thread is closed to new posts. You must sign in to post in the forums.
8/16/2010 12:32:08 PM
Gravatar
Total Posts 18444

Using RAD Editor in mojoPortal

Hi All,

I know that a lot of .NET shops and developers have licenses to Telerik RAD Controls and I'm sure some of you have implemented your own editor provider to plug it into mojoPortal. For those who do have the Telerik RAD controls but don't know how to or don't have the time to develop your own editor provider to plug in the RAD Editor, I've created a new product mojoRadGlue Editor Provider, to make the integration easy for you. Priced at only $19 with source code included it can save you some time at a reasonable price.

Best,

Joe

9/7/2010 3:59:45 PM
Gravatar
Total Posts 245
mojoPortal Community Expert

Re: Using RAD Editor in mojoPortal

Holly Cow Batman (doesn't this tell my age)

Wow... Great!  This one slipped right by me and I wanted it, needed it and for $9 bucks, it's a steal.

Telerik offers a way and details to use a RadEditor in a text box and I we use this in our mojoPortal  feature.

I know after reading here that this plug-in does not do everything yet, but what a great kick start!

Order on the way.

Thanks so much Joe.

9/8/2010 6:57:33 AM
Gravatar
Total Posts 18444

Re: Using RAD Editor in mojoPortal

Hey Rick,

Glad to hear it! I think you are the first one to buy a copy. I haven't really promoted it with a blog post or anything, just kind of soft launched it with this forum post announcement. It will be interesting to see how many people are using Telerik with mojoPortal and I figure sales of this editor provider will be a good indicator over time.

Thanks also to your colleague Laurena, who sent a nice donation!

Best,

Joe 

9/20/2010 12:04:46 AM
Gravatar
Total Posts 245
mojoPortal Community Expert

Re: Using RAD Editor in mojoPortal

Hi Joe

Just installed on a new fresh install.
mojoportal-2-3-5-2-mssql-net40-deploymentfile
Windows 2008 Server IIS 7 Integrated Pipeline Mode
Dot.net 4.0
Latest Telerik.Web.UI.dll from the Bin40

Followed all directions.  changed User and Web.Config

From mojpPortal Site Admin The dropdown now included The Telerik Editor.
I selected it.  Saved.  When I when to edit a pages content I got these errors.

2010-09-19 21:44:07,970 ERROR mojoPortal.Web.mojoBasePage - 96.45.104.2-en-US - /HtmlEdit.aspx?mid=1&pageid=1
System.NullReferenceException: Object reference not set to an instance of an object.
   at mojoPortal.Web.SiteUtils.SetupEditor(EditorControl editor, Boolean useSkinCss, String preferredProvider)
   at System.Web.UI.Page.PerformPreInit()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
2010-09-19 21:44:08,048 ERROR mojoPortal.Web.Global - 96.45.104.2-en-US - /HtmlEdit.aspx?mid=1&pageid=1
System.NullReferenceException: Object reference not set to an instance of an object.
   at mojoPortal.Web.SiteUtils.SetupEditor(EditorControl editor, Boolean useSkinCss, String preferredProvider)
   at System.Web.UI.Page.PerformPreInit()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

maybe I'm missing something?

9/20/2010 10:02:43 AM
Gravatar
Total Posts 18444

Re: Using RAD Editor in mojoPortal

I would review all steps again and make sure all the files landed where they need to go and have at least read permissions on them and maybe try recycle the app pool after that.

9/20/2010 9:43:00 PM
Gravatar
Total Posts 245
mojoPortal Community Expert

Re: Using RAD Editor in mojoPortal

Hi Joe

Today I upgraded a different site from Dot.Net 3.5 to Dot.Net 4.0 with the new version 2.3.5.3 MSSQL that you just released.

I tried IIS 7 with a Classic Application pool this time and the upgrade went fine.

Then I followed the instructions extra careful for IIS 7 with a Classic.  I checked all files copied in and had read access.

For both IIS setups I followed the instructions in this video..

http://www.mojoportal.com/manual-installation-in-iis-75-with-mssql.aspx

and had to use NETWORK SERVICE instead of ApplicationPoolIdentity in the IIS pools.
I checked the Telerik dll and it was for Dot.NET 4.

I stopped and started the pool in IIS

Again, the Telerik Editor option shows up in the drop down and saves, but when I open a page to edit, I get the same errors??

2010-09-20 19:26:43,786 ERROR mojoPortal.Web.mojoBasePage - 70.66.132.207-en-US - /HtmlEdit.aspx?mid=3&pageid=3
System.NullReferenceException: Object reference not set to an instance of an object.
   at mojoPortal.Web.SiteUtils.SetupEditor(EditorControl editor, Boolean useSkinCss, String preferredProvider)
   at System.Web.UI.Page.PerformPreInit()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
2010-09-20 19:26:43,794 ERROR mojoPortal.Web.Global - 70.66.132.207-en-US - /HtmlEdit.aspx?mid=3&pageid=3
System.NullReferenceException: Object reference not set to an instance of an object.
   at mojoPortal.Web.SiteUtils.SetupEditor(EditorControl editor, Boolean useSkinCss, String preferredProvider)
   at System.Web.UI.Page.PerformPreInit()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
 

9/21/2010 5:54:40 AM
Gravatar
Total Posts 18444

Re: Using RAD Editor in mojoPortal

I will take a look at this today and see if I can reproduce the issue.

Not sure why you are using a Classic app pool, I recommend use Integrated

Best,

Joe

9/21/2010 9:14:33 AM
Gravatar
Total Posts 18444

Re: Using RAD Editor in mojoPortal

Ok, I figured it out. I released the mojoRadGlue Editor provider on August 16 and it was compiled against the version of Telerik available then which was version 2010.2.713.40

On August 26 Telerik released a new version 2010.2.826.40

so you need to add this to the web.config inside the <configuration section but not inside any other section, to map it to the newer version.

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
   <assemblyIdentity name="Telerik.Web.UI"
       publicKeyToken="121fae78165ba3d4" />
        <bindingRedirect oldVersion="2010.2.713.40"
  newVersion="2010.2.826.40" />
</dependentAssembly>
</assemblyBinding>
</runtime>

and for any future version of Telerik you will have to keep changing it to map to the new version.

Note that the versions shown above are for .NET 4 and would be different for .NET 3.5, the last 2 digits seem to indicate the .NET version so for 3.5 it would be like this:

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
   <assemblyIdentity name="Telerik.Web.UI"
       publicKeyToken="121fae78165ba3d4" />
        <bindingRedirect oldVersion="2010.2.713.35"
  newVersion="2010.2.826.35" />
</dependentAssembly>
</assemblyBinding>
</runtime>

Best,

Joe

9/21/2010 11:10:02 AM
Gravatar
Total Posts 245
mojoPortal Community Expert

Re: Using RAD Editor in mojoPortal

Thanks Joe...  As you already know, it works now!

The Telerik RadEditor with image manager, upload, image editor, etc. all work GREAT!

I added the new section of markup into the Web.Config file at the very bottom just above </configuration>.
I'm using newVersion="2010.2.908.40" and left bindingRedirect oldVersion="2010.2.713.40".
I am assuming I never have to change oldVersion???

I had tried this setup on Classic app pool and Integrated pool.  It works on both, but I have switched all to Integrated.

Thanks for looking into this so fast.

Couple of beer on the way.

Rick

9/22/2010 7:25:59 AM
Gravatar
Total Posts 18444

Re: Using RAD Editor in mojoPortal

Hi Rick,

Thanks as always for the beers! Most appreciated!

It is possible/likely that whenever I make any new release of the editor provider I will compile it against a newer version of Telerik than the one I used for the initial release.

Let's say for example that I went ahead today and made a new release compiled against the new version. In that case the setting in your web.config doesn't need to change but is not needed anymore. That setting would only be used if a component is asking for that specific version of Telerik then it would allow giving it a different version, but if my new version of mojoRadGlue is asking for the version you already have in the bin then no assembly redirect binding is needed but that old setting in Web.config isn't hurting anything.

But as long as you continue to use the current version of mojoRadGlue that you have, you will only need to edit the newVersion settings whenever you get a newer version of Telerik. I'm not expecting to make lots of releases to mojoRadGlue, but it is likely there will be some updates to it over time.

Best,

Joe

1/29/2011 1:25:25 PM
Gravatar
Total Posts 245
mojoPortal Community Expert

Re: Using RAD Editor in mojoPortal

Hi Joe

Creating Content Templates .

Would it be easy for me or you to add the "Creating Content Templates " button to the Telerik RadEditor.

Or is it simply easier to switch Editors first to get the Template and then switch back to the RadEditor.

Thanks

Rick

You must sign in to post in the forums. This thread is closed to new posts.